Compiling PHP 5.3.1 with mcrypt on Snow Leopard en

By --MeAngry-- on Thursday 3 December 2009 17:17 - Comments (6)
Categories: PHP, Snow Leopard, Views: 14.514

Today I will be posting my first (useful) blog post ever!

Maybe not such a big deal for you, but definitely for me. Maybe even for others if this helps anybody out.
I've decided that I want to share solutions I find to problems that I face in my daily work as a web developer, so that others might have an easier time figuring things out.

I will discuss compiling PHP 5.3 on Snow Leopard to begin with.
Why? I hear you asking, because Snow Leopard already comes supplied with a pretty decent 5.3 version.
Well, because I do all of my web developing work on OS X and like an up to date version running with all the extensions I need.
One of which is the mcrypt extension, which isn't enabled by Apple by default, but for example, is needed by phpMyAdmin on 64-bit PHP installations.

Read more »